Interface that the Revit UI will call, if present, to construct the FrameworkElement
for the pane.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public interface IFrameworkElementCreator |
Visual Basic |
---|
Public Interface IFrameworkElementCreator |
Visual C++ |
---|
public interface class IFrameworkElementCreator |
Examples

// // Class implementing the interface used in Revit to // on demand create the pane UI. // internal class BrowserCreator : IFrameworkElementCreator { // // Implement the creation call back by returning a // new WebBrowser each time the callback is triggered. // public FrameworkElement CreateFrameworkElement() { return new WebBrowser(); } }

' ' Class implementing the interface used in Revit to ' on demand create the pane UI. ' Friend Class BrowserCreator Implements IFrameworkElementCreator ' ' Implement the creation call back by returning a ' new WebBrowser each time the callback is triggered. ' Public Function CreateFrameworkElement() As FrameworkElement Implements IFrameworkElementCreator.CreateFrameworkElement Return New WebBrowser() End Function End Class