Construct a BRepBuilder to use in constructing geometry.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public BRepBuilder( BRepType geomType ) |
Visual Basic |
---|
Public Sub New ( _ geomType As BRepType _ ) |
Visual C++ |
---|
public: BRepBuilder( BRepType geomType ) |
Parameters
- geomType
- Type: Autodesk.Revit.DB..::..BRepType
Specifies the expected type of the output geometry.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |