This class defines an enumerative type used to specify the type of output geometry expected from a BRepBuilder.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Since: 2016
Syntax
C# |
---|
public enum BRepType |
Visual Basic |
---|
Public Enumeration BRepType |
Visual C++ |
---|
public enum class BRepType |
Members
Member name | Description |
---|---|
OpenShell | The output geometry is expected to represent an open shell. |
Solid | The output geometry is expected to represent a (possibly disconnected) solid. |
Void | The output geometry is expected to represent a (possibly disconnected) void (i.e., an inverted solid). |