Identifies whether the curve representing the datum plane is displayed according to its actual 3d extents, or else according to a view specific setting.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public DatumExtentType GetDatumExtentTypeInView( DatumEnds datumEnd, View view ) |
Visual Basic |
---|
Public Function GetDatumExtentTypeInView ( _ datumEnd As DatumEnds, _ view As View _ ) As DatumExtentType |
Visual C++ |
---|
public: DatumExtentType GetDatumExtentTypeInView( DatumEnds datumEnd, View^ view ) |
Parameters
- datumEnd
- Type: Autodesk.Revit.DB..::..DatumEnds
Specifies one end of the curve representing the datum plane in the view.
- view
- Type: Autodesk.Revit.DB..::..View
The view in which to evaluate the datum extent settings.
Return Value
The extent type.
Remarks
In a particular view, the datum plane is represented by a curve and the two ends of the curve may have different DatumExtentTypes in that view.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The datum plane cannot be visible in the view. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |