Implement this method to construct the IPointCloudAccess interface for the point cloud designated by
the identifier. This method is called once during the creation of a PointCloudType.
Namespace: Autodesk.Revit.DB.PointCloudsAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
IPointCloudAccess CreatePointCloudAccess( string identifier ) |
Visual Basic |
---|
Function CreatePointCloudAccess ( _ identifier As String _ ) As IPointCloudAccess |
Visual C++ |
---|
IPointCloudAccess^ CreatePointCloudAccess( String^ identifier ) |
Parameters
- identifier
- Type: System..::..String
An identifier unique to the point cloud. This will be a file name if the engine was registered as file-based, or an arbitrary identifier if the engine is not file-based.
Return Value
The object that can be used to create iterators and interrogate the point cloud for its features.
Remarks
The instance of the returned IPointCloudAccess is then used by Revit to
display instances of the point cloud in Revit graphics and in the user interface.