An interface that controls the behavior of the link from Revit to a custom Point Cloud Engine.
Namespace: Autodesk.Revit.DB.PointCloudsAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public interface IPointCloudEngine |
Visual Basic |
---|
Public Interface IPointCloudEngine |
Visual C++ |
---|
public interface class IPointCloudEngine |
Remarks
An instance of this interface should be created by the engine provider
and registered with the PointCloudEnginesRegistry. The engine may associated
with a particular file name extension during registration (for example,
Revit supplies a built-in engine for working with files with the extension "pcg").
Alternatively, the engine may be associated with an identifier which is not expected
to the be the extension of a particular file.