Subscribe to this event to be notified when a Revit GenericDockableFrame has gained focus or lost focus in the Revit user interface. This event is called only for API-created GenericDockableFrames.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2015

Syntax

C#
public event EventHandler<DockableFrameFocusChangedEventArgs> DockableFrameFocusChanged
Visual Basic
Public Event DockableFrameFocusChanged As EventHandler(Of DockableFrameFocusChangedEventArgs)
Visual C++
public:
 event EventHandler<DockableFrameFocusChangedEventArgs^>^ DockableFrameFocusChanged {
	void add (EventHandler<DockableFrameFocusChangedEventArgs^>^ value);
	void remove (EventHandler<DockableFrameFocusChangedEventArgs^>^ value);
}

Remarks

This event is raised when the GenericDockableFrame is just about to be active or inactive.

Event is not cancellable. The 'Cancellable' property of event's argument is always False.

No document may be modified at the time of the event.

The following API functions are not available for the current document during this event:

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also