The base interface class for all single-server services.
Namespace: Autodesk.Revit.DB.ExternalServiceAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public interface ISingleServerService : IExternalService |
Visual Basic |
---|
Public Interface ISingleServerService _ Inherits IExternalService |
Visual C++ |
---|
public interface class ISingleServerService : IExternalService |
Remarks
Both single-server and multi-server services may have more than one server registered for them. The difference between these two kinds is while there can only be one active server at any given time for a single-sever service, there may be a set of active servers assigned for a multi-server service.
ISingleServerService does not have any specific methods (currently) added to those inherited from the common IExternalService interface.