The base interface class for all external services.
Namespace: Autodesk.Revit.DB.ExternalServiceAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public interface IExternalService |
Visual Basic |
---|
Public Interface IExternalService |
Visual C++ |
---|
public interface class IExternalService |
Remarks
Both supported kinds of services - single-server and multi-server - will derive their classes from this interface, albeit indirectly through an interface specific to the particular kind. External services never derive directly from this class - they always have to derive from either ISingleServerService or IMultiServerService, respectivelly.