Sets the alignment method for a given selector.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public void SetAlignmentMethod( AnalyticalElementSelector selector, AnalyticalAlignmentMethod method ) |
Visual Basic |
---|
Public Sub SetAlignmentMethod ( _ selector As AnalyticalElementSelector, _ method As AnalyticalAlignmentMethod _ ) |
Visual C++ |
---|
public: void SetAlignmentMethod( AnalyticalElementSelector selector, AnalyticalAlignmentMethod method ) |
Parameters
- selector
- Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
End of the analytical model.
- method
- Type: Autodesk.Revit.DB.Structure..::..AnalyticalAlignmentMethod
The alignment method at a given end.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |