Collects all the target geometry from the input geometry object and adds it as IFC handles
to the IFCInfo.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static void CollectGeometryInfo( ExporterIFC exporterIFC, IFCGeometryInfo geometryInfo, GeometryObject gNode, XYZ offset, bool forceVisible, Transform transform ) |
Visual Basic |
---|
Public Shared Sub CollectGeometryInfo ( _ exporterIFC As ExporterIFC, _ geometryInfo As IFCGeometryInfo, _ gNode As GeometryObject, _ offset As XYZ, _ forceVisible As Boolean, _ transform As Transform _ ) |
Visual C++ |
---|
public: static void CollectGeometryInfo( ExporterIFC^ exporterIFC, IFCGeometryInfo^ geometryInfo, GeometryObject^ gNode, XYZ^ offset, bool forceVisible, Transform^ transform ) |
Parameters
- exporterIFC
- Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
- geometryInfo
- Type: Autodesk.Revit.DB.IFC..::..IFCGeometryInfo
The container object which collects the geometry.
- gNode
- Type: Autodesk.Revit.DB..::..GeometryObject
The geometry object to be processed.
- offset
- Type: Autodesk.Revit.DB..::..XYZ
The offset to apply to each of the collected geometry handles.
- forceVisible
- Type: System..::..Boolean
True to process geometry which is not set as visible. False to only process visible geometry.
- transform
- Type: Autodesk.Revit.DB..::..Transform
An overall transform to apply to each of the collected geometry handles.
Remarks
The type of geometry collected is determined by the method of creation for the IFCGeometryInfo.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |