Sets the options to use for this DirectShape.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public void SetOptions( DirectShapeOptions options ) |
Visual Basic |
---|
Public Sub SetOptions ( _ options As DirectShapeOptions _ ) |
Visual C++ |
---|
public: void SetOptions( DirectShapeOptions^ options ) |
Parameters
- options
- Type: Autodesk.Revit.DB..::..DirectShapeOptions
Options to use for this DirectShape.
Remarks
The new options take effect immediately.
If this DirectShape relies on a DirectShapeType for references, the options stored in DirectShapeType take precedence.
Note that changing options affects how the object interacts with Revit. E.g., switching references off will disable
existing constraints applied to that object.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The DirectShapeOptions provided are not valid for this DirectShape. -or- The DirectShapeOptions provided are not valid for this transient DirectShape. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |