Gets the filters applied to the view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public ICollection<ElementId> GetFilters() |
Visual Basic |
---|
Public Function GetFilters As ICollection(Of ElementId) |
Visual C++ |
---|
public: ICollection<ElementId^>^ GetFilters() |
Return Value
The ElementIds of the Filters.
Remarks
Note that this method returns filters in a set sorted according to their ids.
To get filters in the order they are applied to the view use GetOrderedFilters()()()().
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | View does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes. |