Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public virtual KeyValuePair<ExportLayerKey, ExportLayerInfo> Current { get; }
Visual Basic
Public Overridable ReadOnly Property Current As KeyValuePair(Of ExportLayerKey, ExportLayerInfo)
	Get
Visual C++
public:
virtual property KeyValuePair<ExportLayerKey^, ExportLayerInfo^> Current {
	KeyValuePair<ExportLayerKey^, ExportLayerInfo^> get ();
}

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

Remarks

There is no current item if the iterator has not started yet or has been done.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..InvalidOperationException There is no current item in the iterator.

See Also