Creates a new SolidOptions class with material and graphics style settings.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public SolidOptions( ElementId materialId, ElementId graphicsStyleId ) |
Visual Basic |
---|
Public Sub New ( _ materialId As ElementId, _ graphicsStyleId As ElementId _ ) |
Visual C++ |
---|
public: SolidOptions( ElementId^ materialId, ElementId^ graphicsStyleId ) |
Parameters
- materialId
- Type: Autodesk.Revit.DB..::..ElementId
The material id for the Solid.
- graphicsStyleId
- Type: Autodesk.Revit.DB..::..ElementId
The graphics style id for the Solid.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |