Constructs a new instance of a RoutingConditions object with an indicated
error level for conditions that do not meet any routing preference rule.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public RoutingConditions( RoutingPreferenceErrorLevel errorLevel ) |
Visual Basic |
---|
Public Sub New ( _ errorLevel As RoutingPreferenceErrorLevel _ ) |
Visual C++ |
---|
public: RoutingConditions( RoutingPreferenceErrorLevel errorLevel ) |
Parameters
- errorLevel
- Type: Autodesk.Revit.DB..::..RoutingPreferenceErrorLevel
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |