Determines if the given Analyze As parameter is valid for this Element.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public bool IsAnalyzeAsValid( AnalyzeAs analyzeAs ) |
Visual Basic |
---|
Public Function IsAnalyzeAsValid ( _ analyzeAs As AnalyzeAs _ ) As Boolean |
Visual C++ |
---|
public: bool IsAnalyzeAsValid( AnalyzeAs analyzeAs ) |
Parameters
- analyzeAs
- Type: Autodesk.Revit.DB.Structure..::..AnalyzeAs
Indicates how Analytical Model is analyzed.
Return Value
True if valid; false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |