Takes a horizontal slice through a sample wall to which this CompoundStructure is applied
and returns a simple compound structure which describes that slice, i.e. a series of
parallel layers.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public CompoundStructure GetSimpleCompoundStructure( double wallHeight, double distAboveBase ) |
Visual Basic |
---|
Public Function GetSimpleCompoundStructure ( _ wallHeight As Double, _ distAboveBase As Double _ ) As CompoundStructure |
Visual C++ |
---|
public: CompoundStructure^ GetSimpleCompoundStructure( double wallHeight, double distAboveBase ) |
Parameters
- wallHeight
- Type: System..::..Double
The height of the wall.
- distAboveBase
- Type: System..::..Double
The distance from the base of the wall at which to take the section. If distAboveBase < 0, then internally distAboveBase = 0 is used. If distAboveBase > wallHeight, then internally distAboveBase = wallHeight is used.
Return Value
A simple CompoundStructure representing a series of parallel layers.
Remarks
If IsVerticallyCompound is false, the output is a copy of this CompoundStructure.