Obtains the transform for the door or window instance.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static Transform GetTransformForDoorOrWindow( FamilyInstance familyInstance, FamilySymbol familySymbol, bool flippedX, bool flippedY ) |
Visual Basic |
---|
Public Shared Function GetTransformForDoorOrWindow ( _ familyInstance As FamilyInstance, _ familySymbol As FamilySymbol, _ flippedX As Boolean, _ flippedY As Boolean _ ) As Transform |
Visual C++ |
---|
public: static Transform^ GetTransformForDoorOrWindow( FamilyInstance^ familyInstance, FamilySymbol^ familySymbol, bool flippedX, bool flippedY ) |
Parameters
- familyInstance
- Type: Autodesk.Revit.DB..::..FamilyInstance
The family instance.
- familySymbol
- Type: Autodesk.Revit.DB..::..FamilySymbol
The family symbol.
- flippedX
- Type: System..::..Boolean
Is the door or window flipped in X?
- flippedY
- Type: System..::..Boolean
Is the door or window flipped in Y?
Return Value
The transform.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |