Creates a new detail curve element.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public DetailCurve NewDetailCurve( View view, Curve geometryCurve ) |
Visual Basic |
---|
Public Function NewDetailCurve ( _ view As View, _ geometryCurve As Curve _ ) As DetailCurve |
Visual C++ |
---|
public: DetailCurve^ NewDetailCurve( View^ view, Curve^ geometryCurve ) |
Parameters
- view
- Type: Autodesk.Revit.DB..::..View
The view in which the detail curve is to be visible.
- geometryCurve
- Type: Autodesk.Revit.DB..::..Curve
The internal geometry curve for detail curve. It should be a bound curve.
Return Value
If successful a new detail curve element. Otherwise nullNothingnullptra null reference (Nothing in Visual Basic).
Remarks
Different type of detail curve element will be returned according to the type of geometry curve.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when curve is not in plane of the view |