Calculates the intersection of the specified curve with this face.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public SetComparisonResult Intersect( Curve curve ) |
Visual Basic |
---|
Public Function Intersect ( _ curve As Curve _ ) As SetComparisonResult |
Visual C++ |
---|
public: SetComparisonResult Intersect( Curve^ curve ) |
Parameters
- curve
- Type: Autodesk.Revit.DB..::..Curve
The specified curve to intersect with this face.
Return Value
- SetComparisonResult.Overlap - One or more intersections were encountered.
- SetComparisonResult.Subset - The curve is coincident with the surface.
- SetComparisonResult.Disjoint - There is no intersection found.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | The curve is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The intersection calculation fails. |