An enumerated type listing all the relationship types between two sets of arbitrary nature.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public enum SetComparisonResult |
Visual Basic |
---|
Public Enumeration SetComparisonResult |
Visual C++ |
---|
public enum class SetComparisonResult |
Members
Member name | Description |
---|---|
LeftEmpty | The left set is empty and the right set is not. |
RightEmpty | The right set is empty and the left set is not. |
BothEmpty | Both sets are empty. |
Disjoint | Both sets are not empty and don't overlap. |
Overlap | The overlap of two sets is not empty and strict subset of both. |
Subset | Both sets are not empty and the left set is strict subset of the right. |
Superset | Both sets are not empty and the left set is strict superset of the right. |
Equal | Two nonempty sets are equal. |