Creates a new radial array from a set of elements based
on an input rotation axis.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
Visual Basic |
---|
Public Shared Function ArrayElementsWithoutAssociation ( _
aDoc As Document, _
dBView As View, _
ids As ICollection(Of ElementId), _
count As Integer, _
axis As Line, _
angle As Double, _
anchorMember As ArrayAnchorMember _
) As ICollection(Of ElementId) |
Parameters
- aDoc
- Type: Autodesk.Revit.DB..::..Document
The document.
- dBView
- Type: Autodesk.Revit.DB..::..View
The view. If it is a 2d view, translation vector must be in the view plane if elements include view-specific elements.
If elements include view-specific elements, they must belong to this view.
- ids
- Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
The set of elements to array. The position of the rotation
axis is determined by the cumulative center of the elements' bounding boxes.
- count
- Type: System..::..Int32
The number of array members to create. The accepted range is from 3 to 200.
- axis
- Type: Autodesk.Revit.DB..::..Line
The rotation axis.
- angle
- Type: System..::..Double
The angle in radians of the rotation.
- anchorMember
- Type: Autodesk.Revit.DB..::..ArrayAnchorMember
Indicates if the translation vector specifies the location of the second member
of the array, or the last member of the array.
Return Value
The elements created by the operation.
Remarks
Exceptions
See Also