Gets the spatial element boundary location based on spatial element type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public SpatialElementBoundaryLocation GetSpatialElementBoundaryLocation( SpatialElementType spType ) |
Visual Basic |
---|
Public Function GetSpatialElementBoundaryLocation ( _ spType As SpatialElementType _ ) As SpatialElementBoundaryLocation |
Visual C++ |
---|
public: SpatialElementBoundaryLocation GetSpatialElementBoundaryLocation( SpatialElementType spType ) |
Parameters
- spType
- Type: Autodesk.Revit.DB..::..SpatialElementType
The spatial element type.
Return Value
The boundary location.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |