The number of normals associated with the polymesh
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public int NumberOfNormals { get; } |
Visual Basic |
---|
Public ReadOnly Property NumberOfNormals As Integer Get |
Visual C++ |
---|
public: property int NumberOfNormals { int get (); } |
Remarks
The number is always equal either to '1', or the number of facets,
or the number of points. The DistributionOfNormals property indicates
how normals are distributed along the polymesh. If there is only one normal available,
it applies to the entire mesh. Curved surfaces have normal vectors associated
with either every facet or every point/vertex of the tessellated polymesh.