Constructs a ReferenceIntersector which is set to return intersections from any element which passes an input filter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public ReferenceIntersector( ElementFilter filter, FindReferenceTarget targetType, View3D view3d ) |
Visual Basic |
---|
Public Sub New ( _ filter As ElementFilter, _ targetType As FindReferenceTarget, _ view3d As View3D _ ) |
Visual C++ |
---|
public: ReferenceIntersector( ElementFilter^ filter, FindReferenceTarget targetType, View3D^ view3d ) |
Parameters
- filter
- Type: Autodesk.Revit.DB..::..ElementFilter
The element filter. All references will belong to elements passing this filter.
- targetType
- Type: Autodesk.Revit.DB..::..FindReferenceTarget
The target type of references to return.
- view3d
- Type: Autodesk.Revit.DB..::..View3D
The view in which to find references.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Returns true if the view is not a view template. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |