Creates a new StructuralConnectionApprovalType.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public static StructuralConnectionApprovalType Create( Document doc, string name ) |
Visual Basic |
---|
Public Shared Function Create ( _ doc As Document, _ name As String _ ) As StructuralConnectionApprovalType |
Visual C++ |
---|
public: static StructuralConnectionApprovalType^ Create( Document^ doc, String^ name ) |
Parameters
- doc
- Type: Autodesk.Revit.DB..::..Document
- name
- Type: System..::..String
A name for the new approval type. It must be unique within the document.
Return Value
Created connection approval type.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The input name for approval type is not unique in the document. |