Creates a new opening in a roof, floor and ceiling.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
Visual Basic |
---|
Public Function NewOpening ( _
hostElement As Element, _
profile As CurveArray, _
bPerpendicularFace As Boolean _
) As Opening |
Parameters
- hostElement
- Type: Autodesk.Revit.DB..::..Element
Host element of the opening. Can be a roof, floor, or ceiling.
- profile
- Type: Autodesk.Revit.DB..::..CurveArray
Profile of the opening.
- bPerpendicularFace
- Type: System..::..Boolean
True if the profile is cut perpendicular to the intersecting face of the host. False if the profile is cut vertically.
Return Value
If successful, an Opening object is returned.
Exceptions
See Also