Checks if rebarShape matches curves, hooks and end treatment.
If the RebarShapeDefinesHooks flag in ReinforcementSettings has been set to false, then this method will ignore the hook information.
If the RebarShapeDefinesEndTreatment flag in ReinforcementSettings has been set to false, then this method will ignore the end treatment information.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2021
Syntax
C# |
---|
public static bool RebarShapeMatchesCurvesHooksAndEndTreatment(
RebarShape rebarShape,
RebarBarType barType,
XYZ norm,
IList<Curve> curves,
RebarHookType startHook,
RebarHookType endHook,
RebarHookOrientation startHookOrient,
RebarHookOrientation endHookOrient,
double hookRotationAngleAtStart,
double hookRotationAngleAtEnd,
ElementId endTreatmentTypeIdAtStart,
ElementId endTreatmentTypeIdAtEnd
) |
Visual Basic |
---|
Public Shared Function RebarShapeMatchesCurvesHooksAndEndTreatment ( _
rebarShape As RebarShape, _
barType As RebarBarType, _
norm As XYZ, _
curves As IList(Of Curve), _
startHook As RebarHookType, _
endHook As RebarHookType, _
startHookOrient As RebarHookOrientation, _
endHookOrient As RebarHookOrientation, _
hookRotationAngleAtStart As Double, _
hookRotationAngleAtEnd As Double, _
endTreatmentTypeIdAtStart As ElementId, _
endTreatmentTypeIdAtEnd As ElementId _
) As Boolean |
Visual C++ |
---|
public:
static bool RebarShapeMatchesCurvesHooksAndEndTreatment(
RebarShape^ rebarShape,
RebarBarType^ barType,
XYZ^ norm,
IList<Curve^>^ curves,
RebarHookType^ startHook,
RebarHookType^ endHook,
RebarHookOrientation startHookOrient,
RebarHookOrientation endHookOrient,
double hookRotationAngleAtStart,
double hookRotationAngleAtEnd,
ElementId^ endTreatmentTypeIdAtStart,
ElementId^ endTreatmentTypeIdAtEnd
) |
Parameters
- rebarShape
- Type: Autodesk.Revit.DB.Structure..::..RebarShape
A RebarShape element that defines the shape of the rebar.
- barType
- Type: Autodesk.Revit.DB.Structure..::..RebarBarType
A RebarBarType element that defines bar diameter, bend radius and material of the rebar.
- norm
- Type: Autodesk.Revit.DB..::..XYZ
The normal to the plane that the rebar curves lie on.
- curves
- Type: System.Collections.Generic..::..IList<(Of <(<'Curve>)>)>
An array of curves that define the shape of the rebar curves.
They must belong to the plane defined by the normal and origin.
Bends and hooks should not be included in the array of curves.
- startHook
- Type: Autodesk.Revit.DB.Structure..::..RebarHookType
A RebarHookType element that defines the hook for the start of the bar.
- endHook
- Type: Autodesk.Revit.DB.Structure..::..RebarHookType
A RebarHookType element that defines the hook for the end of the bar.
- startHookOrient
- Type: Autodesk.Revit.DB.Structure..::..RebarHookOrientation
Defines the orientation of the hook plane at the start of the rebar with respect to the orientation of the first curve and the plane normal.
Only two values are permitted:
Value = Right: The hook is on your right as you stand at the end of the bar,
with the bar behind you, taking the bar's normal as "up."
Value = Left: The hook is on your left as you stand at the end of the bar,
with the bar behind you, taking the bar's normal as "up."
- endHookOrient
- Type: Autodesk.Revit.DB.Structure..::..RebarHookOrientation
Defines the orientation of the hook plane at the end of the rebar with respect to the orientation of the last curve and the plane normal.
Only two values are permitted:
Value = Right: The hook is on your right as you stand at the end of the bar,
with the bar behind you, taking the bar's normal as "up."
Value = Left: The hook is on your left as you stand at the end of the bar,
with the bar behind you, taking the bar's normal as "up."
- hookRotationAngleAtStart
- Type: System..::..Double
The out of plane hook rotation angle at the start of the bar.
- hookRotationAngleAtEnd
- Type: System..::..Double
The out of plane hook rotation angle at the end of the bar.
- endTreatmentTypeIdAtStart
- Type: Autodesk.Revit.DB..::..ElementId
The end treatment type id at the start of the bar.
- endTreatmentTypeIdAtEnd
- Type: Autodesk.Revit.DB..::..ElementId
The end treatment type id at the end of the bar.
Return Value
True if rebarShape matches curves and hooks.
Exceptions
See Also