Returns a copy of the ExternalResourceReference currently
in use by the containing element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public ExternalResourceReference GetCurrentlyLoadedReference() |
Visual Basic |
---|
Public Function GetCurrentlyLoadedReference As ExternalResourceReference |
Visual C++ |
---|
public: ExternalResourceReference^ GetCurrentlyLoadedReference() |
Return Value
A copy of the ExternalResourceReference currently in use by the containing element.
Remarks
A server may use to wish this information to, for example, tell whether the Revit user was previously using their server or not.
This reference may be nullNothingnullptra null reference (Nothing in Visual Basic) if there is no current value. For example, a newly-created link being loaded for the first time would have no currently-loaded reference.