This class contains data describing the context related
to an external resource load operation.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public class ExternalResourceLoadContext : IDisposable |
Visual Basic |
---|
Public Class ExternalResourceLoadContext _ Implements IDisposable |
Visual C++ |
---|
public ref class ExternalResourceLoadContext : IDisposable |
Remarks
Note that automatic loads can occur in the context of other operations such as opening a file. During automatic loads, it is therefore recommended that the server only display UI that is critical for the user to see (such as error message).
The loading operation type is Explicit when the user is specifically trying to reload the resource. During explicit loads, it may be desirable to provide more feedback to the user, such as specific feedback that the load operation succeeded.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..ExternalResourceLoadContext
Autodesk.Revit.DB..::..ExternalResourceLoadContext