Gets associated PartMaker for an element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public static PartMaker GetAssociatedPartMaker( Document hostDocument, LinkElementId hostOrLinkElementId ) |
Visual Basic |
---|
Public Shared Function GetAssociatedPartMaker ( _ hostDocument As Document, _ hostOrLinkElementId As LinkElementId _ ) As PartMaker |
Visual C++ |
---|
public: static PartMaker^ GetAssociatedPartMaker( Document^ hostDocument, LinkElementId^ hostOrLinkElementId ) |
Parameters
- hostDocument
- Type: Autodesk.Revit.DB..::..Document
The document
- hostOrLinkElementId
- Type: Autodesk.Revit.DB..::..LinkElementId
The id for the element to be checked for associated Parts
Return Value
The PartMaker element that is making Parts for this element. nullNothingnullptra null reference (Nothing in Visual Basic) if there is no associated PartMaker.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |