Adds a new sorting/grouping field at the specified position in the list.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public void InsertSortGroupField( ScheduleSortGroupField sortGroupField, int index ) |
Visual Basic |
---|
Public Sub InsertSortGroupField ( _ sortGroupField As ScheduleSortGroupField, _ index As Integer _ ) |
Visual C++ |
---|
public: void InsertSortGroupField( ScheduleSortGroupField^ sortGroupField, int index ) |
Parameters
- sortGroupField
- Type: Autodesk.Revit.DB..::..ScheduleSortGroupField
The sorting/grouping field to add.
- index
- Type: System..::..Int32
The index in the list of sorting/grouping fields.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The field ID is not the ID of a field in this ScheduleDefinition. -or- The field cannot be used for sorting/grouping. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid insert position. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The resulting sorting/grouping field count would be greater than 4. |