Returns a reference that corresponds to the face to which the RebarConstraint is attached specified by the targetIndex.
The RebarConstraintType of the RebarConstraint must be 'FixedDistanceToHostFace' or 'ToCover.'
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2018
Syntax
C# |
---|
public Reference GetTargetHostFaceReference(
int targetIndex
) |
Visual Basic |
---|
Public Function GetTargetHostFaceReference ( _
targetIndex As Integer _
) As Reference |
Visual C++ |
---|
public:
Reference^ GetTargetHostFaceReference(
int targetIndex
) |
Parameters
- targetIndex
- Type: System..::..Int32
The index of the target. Should be between 0 and NumberOfTargets().
Return Value
Requested reference.
Exceptions
See Also