Get the hook angle, expressed as an integral number of degrees (common values are 0, 90, 135, and 180).
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public int GetDefaultHookAngle( int index ) |
Visual Basic |
---|
Public Function GetDefaultHookAngle ( _ index As Integer _ ) As Integer |
Visual C++ |
---|
public: int GetDefaultHookAngle( int index ) |
Parameters
- index
- Type: System..::..Int32
0 for the starting hook, 1 for the ending hook.
Remarks
Replaces the method GetHookAngle() from prior releases.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index must be 0 or 1. |