Changes the name of the transaction for which failures are being processed.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public void SetTransactionName( string transactionName ) |
Visual Basic |
---|
Public Sub SetTransactionName ( _ transactionName As String _ ) |
Visual C++ |
---|
public: void SetTransactionName( String^ transactionName ) |
Parameters
- transactionName
- Type: System..::..String
The name of the transaction to set.
Remarks
If the transaction will be committed by or after failures processing it can change its name to reflect
results of processing of the failures. For example, if the original transaction name was "review warnings" and
some of the warnings were resolved by deleting of the relevant elements, failures processor may
change the name of the transaction to "delete elements".
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | transactionName is an empty string. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This FailuresAccessor is inactive (is used outside of failures processing). |