Change the first edge or curve reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public void SetEdgeReference1(
	Reference edgeReference
)
Visual Basic
Public Sub SetEdgeReference1 ( _
	edgeReference As Reference _
)
Visual C++
public:
void SetEdgeReference1(
	Reference^ edgeReference
)

Parameters

edgeReference
Type: Autodesk.Revit.DB..::..Reference

Remarks

The referenced element may be any model element, including FamilyInstance, FormElement, or NonPlanarSketch. The reference must be of type ElementReferenceType.REFERENCE_TYPE_LINEAR, and it must correspond to a straight line.

See Also