Define a ReferencePoint at the intersection of two
referenceable lines.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public class PointOnEdgeEdgeIntersection : PointElementReference |
Visual Basic |
---|
Public Class PointOnEdgeEdgeIntersection _ Inherits PointElementReference |
Visual C++ |
---|
public ref class PointOnEdgeEdgeIntersection : public PointElementReference |
Remarks
The ReferencePoint is actually placed on the first
line (Edge1) at the closest point to the second line (Edge2).
Its X basis vector is constrained to be parallel to the first
line.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..PointElementReference
Autodesk.Revit.DB..::..PointOnEdgeEdgeIntersection
Autodesk.Revit.DB..::..PointElementReference
Autodesk.Revit.DB..::..PointOnEdgeEdgeIntersection