Forces execution order between two updaters
Execution order: first before second
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static void SetExecutionOrder( UpdaterId first, UpdaterId second ) |
Visual Basic |
---|
Public Shared Sub SetExecutionOrder ( _ first As UpdaterId, _ second As UpdaterId _ ) |
Visual C++ |
---|
public: static void SetExecutionOrder( UpdaterId^ first, UpdaterId^ second ) |
Parameters
- first
- Type: Autodesk.Revit.DB..::..UpdaterId
Id of first Updater
- second
- Type: Autodesk.Revit.DB..::..UpdaterId
Id of second Updater
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | One or both inputs are not valid UpdaterIds -or- One or both of the Updaters are not registered -or- first and second are the same id |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentsInconsistentException | The updaters do not report the same ChangePriority |