Creates a new shaft opening between a set of levels.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public Opening NewOpening( Level bottomLevel, Level topLevel, CurveArray profile ) |
Visual Basic |
---|
Public Function NewOpening ( _ bottomLevel As Level, _ topLevel As Level, _ profile As CurveArray _ ) As Opening |
Visual C++ |
---|
public: Opening^ NewOpening( Level^ bottomLevel, Level^ topLevel, CurveArray^ profile ) |
Parameters
- bottomLevel
- Type: Autodesk.Revit.DB..::..Level
bottom level
- topLevel
- Type: Autodesk.Revit.DB..::..Level
top level
- profile
- Type: Autodesk.Revit.DB..::..CurveArray
profile of the opening.
Return Value
If successful, an Opening object is returned.
Remarks
This method forms an opening on floor, ceiling and roof. Make sure topLevel is higher than bottomLevel, otherwise an exception will be returned.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the bottom level does not exist in the given document. |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the top level does not exist in the given document. |