A validator function that checks whether the loop id corresponds to a loop previously added to this BRepBuilder object.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public bool IsValidLoopId( BRepBuilderGeometryId loopId ) |
Visual Basic |
---|
Public Function IsValidLoopId ( _ loopId As BRepBuilderGeometryId _ ) As Boolean |
Visual C++ |
---|
public: bool IsValidLoopId( BRepBuilderGeometryId^ loopId ) |
Parameters
- loopId
- Type: Autodesk.Revit.DB..::..BRepBuilderGeometryId
Loop id to be validated.
Return Value
True if loopId corresponds to a loop previously added to this BRepBuilder, false otherwise.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |