Query the spatial element boundary face information with the given face.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public IList<SpatialElementBoundarySubface> GetBoundaryFaceInfo( Face face ) |
Visual Basic |
---|
Public Function GetBoundaryFaceInfo ( _ face As Face _ ) As IList(Of SpatialElementBoundarySubface) |
Visual C++ |
---|
public: IList<SpatialElementBoundarySubface^>^ GetBoundaryFaceInfo( Face^ face ) |
Parameters
- face
- Type: Autodesk.Revit.DB..::..Face
The face from the spatial element's geometry.
Return Value
Sub-faces related to the room bounding elements that define the spatial element face. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if there is no corresponding boundary information with the given face.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |