Return the option object that allows you to use Revit's dialog boxes to let the user respond to questions that arise during loading of families.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public static IFamilyLoadOptions GetRevitUIFamilyLoadOptions() |
Visual Basic |
---|
Public Shared Function GetRevitUIFamilyLoadOptions As IFamilyLoadOptions |
Visual C++ |
---|
public: static IFamilyLoadOptions^ GetRevitUIFamilyLoadOptions() |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown if this API method is invoked in UI less mode |