Constructs a new instance of a file to match elements that have a given phase statuses on the input phase, with the option to match all elements that have a phase status other than the input statuses.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2012

Syntax

C#
public ElementPhaseStatusFilter(
	ElementId phaseId,
	ICollection<ElementOnPhaseStatus> phaseStatuses,
	bool inverted
)
Visual Basic
Public Sub New ( _
	phaseId As ElementId, _
	phaseStatuses As ICollection(Of ElementOnPhaseStatus), _
	inverted As Boolean _
)
Visual C++
public:
ElementPhaseStatusFilter(
	ElementId^ phaseId, 
	ICollection<ElementOnPhaseStatus>^ phaseStatuses, 
	bool inverted
)

Parameters

phaseId
Type: Autodesk.Revit.DB..::..ElementId
Id of the phase.
phaseStatuses
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementOnPhaseStatus>)>)>
Target statuses.
inverted
Type: System..::..Boolean
True to match all phase statuses other than the input statuses.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also