The statuses that an element can have with respect to a given phase.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public enum ElementOnPhaseStatus |
Visual Basic |
---|
Public Enumeration ElementOnPhaseStatus |
Visual C++ |
---|
public enum class ElementOnPhaseStatus |
Members
Member name | Description |
---|---|
None | Phase status is undefined (e.g., for annotations) |
Past | Created and demolished before the given phase |
Existing | Created in a previous phase, existing through the end of the given phase |
Demolished | Created before the given phase, to be demolished on the given phase |
New | Created on this phase (and not demolished) |
Temporary | Created and demolished during this phase |
Future | Created after this phase |