Returns the instance that provides implementation for a registered server.
Namespace: Autodesk.Revit.DB.ExternalServiceAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public IExternalServer GetServer( Guid serverId ) |
Visual Basic |
---|
Public Function GetServer ( _ serverId As Guid _ ) As IExternalServer |
Visual C++ |
---|
public: IExternalServer^ GetServer( Guid serverId ) |
Parameters
- serverId
- Type: System..::..Guid
Id of a registered server
Return Value
An instance of the server interface. NULL is returned if the server is invalid (e.g. destroyed)
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The given Id is not a valid GUID value. |