Adds an annotation handle to associate with the IfcProduct in this wrapper.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public void AddAnnotation( IFCAnyHandle annoHnd, IFCLevelInfo levelInfo, bool relateToLevel ) |
Visual Basic |
---|
Public Sub AddAnnotation ( _ annoHnd As IFCAnyHandle, _ levelInfo As IFCLevelInfo, _ relateToLevel As Boolean _ ) |
Visual C++ |
---|
public: void AddAnnotation( IFCAnyHandle^ annoHnd, IFCLevelInfo^ levelInfo, bool relateToLevel ) |
Parameters
- annoHnd
- Type: Autodesk.Revit.DB.IFC..::..IFCAnyHandle
The annotation handle.
- levelInfo
- Type: Autodesk.Revit.DB.IFC..::..IFCLevelInfo
Information on the associated level. Optional, can be nullNothingnullptra null reference (Nothing in Visual Basic).
- relateToLevel
- Type: System..::..Boolean
True to relate the annotation to the level, false otherwise.
Remarks
If the IFCLevelInfo is not provided, and relateToLevel to true, the handle will be associated to the building handle.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |