Gets the profile Family Symbols of the document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static ICollection<ElementId> GetProfileSymbols( Document document, ProfileFamilyUsage profileFamilyUsage, bool oneCurveLoopOnly ) |
Visual Basic |
---|
Public Shared Function GetProfileSymbols ( _ document As Document, _ profileFamilyUsage As ProfileFamilyUsage, _ oneCurveLoopOnly As Boolean _ ) As ICollection(Of ElementId) |
Visual C++ |
---|
public: static ICollection<ElementId^>^ GetProfileSymbols( Document^ document, ProfileFamilyUsage profileFamilyUsage, bool oneCurveLoopOnly ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document.
- profileFamilyUsage
- Type: Autodesk.Revit.DB..::..ProfileFamilyUsage
The profile family usage.
- oneCurveLoopOnly
- Type: System..::..Boolean
Whether or not to return only profiles with one curve loop.
Return Value
The set of profile Family Symbol element ids.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |