An enumerated type listing all types of profile families.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public enum ProfileFamilyUsage |
Visual Basic |
---|
Public Enumeration ProfileFamilyUsage |
Visual C++ |
---|
public enum class ProfileFamilyUsage |
Members
Member name | Description |
---|---|
Any | Any type of profile family. |
WallSweep | Wall sweep. |
Reveal | Reveal. |
Fascia | Fascia. |
Gutter | Gutter. |
SlabEdge | Slab edge. |
Railing | Railing. |
StairNosing | Stair Nosing. |
Mullion | Mullion. |
SlabMetalDeck | Slab Metal Deck. |
ContinuousFooting | Continuous Footing. |
StairTread | Stair Tread. |
StairRiser | Stair Riser. |
StairSupport | Stair Support. |