Sets a custom duplicate type names handler. If this value is not set, the default handler is used.
By default, Revit displays a modal dialog with options to either copy new types only, or cancel the operation.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public void SetDuplicateTypeNamesHandler( IDuplicateTypeNamesHandler handler ) |
Visual Basic |
---|
Public Sub SetDuplicateTypeNamesHandler ( _ handler As IDuplicateTypeNamesHandler _ ) |
Visual C++ |
---|
public: void SetDuplicateTypeNamesHandler( IDuplicateTypeNamesHandler^ handler ) |
Parameters
- handler
- Type: Autodesk.Revit.DB..::..IDuplicateTypeNamesHandler
The duplicate type names handler.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |